Meow scheduled maintenance
Scheduled for April 10, 2025 at 12:49 AM – 1:49 AM
Affects
App
Under maintenance from 12:49 AM to 1:49 AM
Completed
April 10, 2025 at 1:49 AMCompleted
April 10, 2025 at 1:49 AMMaintenance has completed successfully.
In progress
April 10, 2025 at 12:49 AMIn progress
April 10, 2025 at 12:49 AMMaintenance is now in progress
Planned
April 10, 2025 at 12:49 AMPlanned
April 10, 2025 at 12:49 AMMeow is currently undergoing maintenance. We'll be back soon!