Meow scheduled maintenance
Scheduled for February 20, 2025 at 1:49 AM – 2:49 AM
Affects
App
Under maintenance from 1:49 AM to 2:49 AM
Completed
February 20, 2025 at 2:49 AMCompleted
February 20, 2025 at 2:49 AMMaintenance has completed successfully.
In progress
February 20, 2025 at 1:49 AMIn progress
February 20, 2025 at 1:49 AMMaintenance is now in progress
Planned
February 20, 2025 at 1:49 AMPlanned
February 20, 2025 at 1:49 AMMeow is currently undergoing maintenance. We'll be back soon!