Meow scheduled maintenance
Scheduled for February 13, 2025 at 1:57 AM – 3:25 AM
Affects
App
Under maintenance from 1:57 AM to 3:25 AM
Completed
February 13, 2025 at 3:25 AMCompleted
February 13, 2025 at 3:25 AMMaintenance has completed successfully.
In progress
February 13, 2025 at 1:57 AMIn progress
February 13, 2025 at 1:57 AMMaintenance is now in progress
Planned
February 13, 2025 at 1:57 AMPlanned
February 13, 2025 at 1:57 AMMeow is currently undergoing maintenance. We'll be back soon!