Meow scheduled maintenance
Scheduled for January 23, 2024 at 3:52 AM – 4:05 AM
Affects
App
Under maintenance from 3:52 AM to 4:05 AM
Completed
January 23, 2024 at 4:05 AMCompleted
January 23, 2024 at 4:05 AMMaintenance has completed successfully.
In progress
January 23, 2024 at 3:52 AMIn progress
January 23, 2024 at 3:52 AMMaintenance is now in progress
Planned
January 23, 2024 at 3:52 AMPlanned
January 23, 2024 at 3:52 AMMeow is currently undergoing maintenance. We'll be back soon!